Sunday, March 17, 2019

Aruba QuickConnect Onboard Wizard on Ubuntu

The Aruba QuickConnect Onboard Wizard theoretically supports Linux hosts.  If you download the utility from a browser reporting Linux as the host OS, you will get a 47 MB shell script that is mostly a binary blob.  This self-extracts to "/tmp/quickconnect" and runs a binary application from there.  I got a segfault every time that I ran it with no useful error messages.  Unfortunately, the binary is stripped and was quite difficult to reverse - I didn't make in progress trying to debug it. 
It seems that the issue is with one of the libraries that is used only when the Qt app is running in GTK fallback mode.  I got the segfault in standard GNOME Ubuntu 18.04 and in Xubuntu 18.04, but it did not occur in Kubuntu 18.04.  Unfortunately, simply installing kde-desktop on another flavor and running the Qt from inside a KDE session did not seem to work.  My ultimate solution was to install Kubuntu on the relevant device, onboard, and then install another desktop environment.  I prefer to not use KDE due to a bug where apps (to include LibreOffice) are not recognized as an input window by fcitx and pinyin input is an absolute requirement for me.

For some strange reason, the Onboard Wizard failed several times and then worked correctly on Gallium OS on my Chromebook, despite the fact that Gallium OS uses XFCE.

One other item of note is that the Onboard Wizard fails to properly switch from the onboarding network for the 802.11x network.  The wizard will stop at this step, but you can just disconnect and connect to the correct network manually.

TODO: Update this post with the exact error message and screenshots the next time that I get it.

No comments:

Post a Comment